Click or drag to resize

NamedLayerStateTable Methods

The NamedLayerStateTable type exposes the following members.

Methods
  NameDescription
Public methodDelete
Deletes an existing named layer state.
Public methodFindName
Returns the index of an existing named layer state.
Public methodImport
Imports named layer states from a 3dm file.
Public methodRename
Renames an existing named layer state.
Public methodRestore(String, RestoreLayerProperties)
Restores a named layer state.
Public methodRestore(String, RestoreLayerProperties, Guid)
Restores a named layer state.
Public methodSave(String)
Saves or updates a named layer state.
Public methodSave(String, Guid)
Saves or updates a named layer state.
Top
See Also