Click or drag to resize

StringParserParseLengthExpession Method (String, StringParserSettings, UnitSystem, Double)

Parse a string for a length value. Expression can include complex expressions Simplest version of Length parsing

Namespace:  Rhino.Input
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static int ParseLengthExpession(
	string expression,
	StringParserSettings parse_settings_in,
	UnitSystem output_unit_system,
	out double value_out
)

Parameters

expression
Type: SystemString
[In] The string to parse
parse_settings_in
Type: Rhino.InputStringParserSettings
[In] Determines what input will be parsed
output_unit_system
Type: RhinoUnitSystem
[In] Output value is in this unit system
value_out
Type: SystemDouble
[Out] The length value result

Return Value

Type: Int32
Count of characters parsed or 0 for failure
See Also