Vector3dIsPerpendicularTo Method (Vector3d, Double) |
Determines whether this vector is perpendicular to another vector, within a provided angle tolerance.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool IsPerpendicularTo(
Vector3d other,
double angleTolerance
)
Public Function IsPerpendicularTo (
other As Vector3d,
angleTolerance As Double
) As Boolean
Parameters
- other
- Type: Rhino.GeometryVector3d
Vector to use for comparison. - angleTolerance
- Type: SystemDouble
Angle tolerance (in radians).
Return Value
Type:
Booleantrue if vectors form Pi-radians (90-degree) angles with each other; otherwise false.
See Also