Click or drag to resize

Point2fCompareTo Method

Compares this Point2f with another Point2f.

Coordinates evaluation priority is first X, then Y.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public int CompareTo(
	Point2f other
)

Parameters

other
Type: Rhino.GeometryPoint2f
The other Point2f to use in comparison.

Return Value

Type: Int32

0: if this is identical to other

-1: if this.X < other.X

-1: if this.X == other.X and this.Y < other.Y

+1: otherwise.

Implements

IComparableTCompareTo(T)
See Also