Line Constructor (Point3d, Vector3d, Double) |
Constructs a new line segment from start point, direction and length.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public Line(
Point3d start,
Vector3d direction,
double length
)
Public Sub New (
start As Point3d,
direction As Vector3d,
length As Double
)
Parameters
- start
- Type: Rhino.GeometryPoint3d
Start point of line segment. - direction
- Type: Rhino.GeometryVector3d
Direction of line segment. - length
- Type: SystemDouble
Length of line segment.
See Also