Click or drag to resize

MeshFaceListRemoveAt Method (Int32, Boolean)

Removes a face from the mesh.

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.6
Syntax
public void RemoveAt(
	int index,
	bool compact
)

Parameters

index
Type: SystemInt32
The index of the face that will be removed.
compact
Type: SystemBoolean
If true, removes vertices that are no longer referenced.
Exceptions
ExceptionCondition
ArgumentOutOfRangeExceptionIf index is < 0 or >= Count.
See Also