MeshFaceListAddFace Method (Int32, Int32, Int32) |
Appends a new triangular face to the end of the mesh face list.
Namespace:
Rhino.Geometry.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public int AddFace(
int vertex1,
int vertex2,
int vertex3
)
Public Function AddFace (
vertex1 As Integer,
vertex2 As Integer,
vertex3 As Integer
) As Integer
Parameters
- vertex1
- Type: SystemInt32
Index of first face corner. - vertex2
- Type: SystemInt32
Index of second face corner. - vertex3
- Type: SystemInt32
Index of third face corner.
Return Value
Type:
Int32The index of the newly added triangle.
See Also