Circle Constructor (Plane, Point3d, Double) |
Initializes a circle parallel to a given plane with given center and radius.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public Circle(
Plane plane,
Point3d center,
double radius
)
Public Sub New (
plane As Plane,
center As Point3d,
radius As Double
)
Parameters
- plane
- Type: Rhino.GeometryPlane
Plane for circle. - center
- Type: Rhino.GeometryPoint3d
Center point override. - radius
- Type: SystemDouble
Radius of circle (should be a positive value).
See Also