Click or drag to resize

AnnotationBaseFormatRtfString Method

[Missing <summary> documentation for "M:Rhino.Geometry.AnnotationBase.FormatRtfString(System.String,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.String)"]

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static string FormatRtfString(
	string rtf_in,
	bool clear_bold,
	bool set_bold,
	bool clear_italic,
	bool set_italic,
	bool clear_underline,
	bool set_underline,
	bool clear_facename,
	bool set_facename,
	string facename
)

Parameters

rtf_in
Type: SystemString

[Missing <param name="rtf_in"/> documentation for "M:Rhino.Geometry.AnnotationBase.FormatRtfString(System.String,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.String)"]

clear_bold
Type: SystemBoolean

[Missing <param name="clear_bold"/> documentation for "M:Rhino.Geometry.AnnotationBase.FormatRtfString(System.String,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.String)"]

set_bold
Type: SystemBoolean

[Missing <param name="set_bold"/> documentation for "M:Rhino.Geometry.AnnotationBase.FormatRtfString(System.String,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.String)"]

clear_italic
Type: SystemBoolean

[Missing <param name="clear_italic"/> documentation for "M:Rhino.Geometry.AnnotationBase.FormatRtfString(System.String,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.String)"]

set_italic
Type: SystemBoolean

[Missing <param name="set_italic"/> documentation for "M:Rhino.Geometry.AnnotationBase.FormatRtfString(System.String,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.String)"]

clear_underline
Type: SystemBoolean

[Missing <param name="clear_underline"/> documentation for "M:Rhino.Geometry.AnnotationBase.FormatRtfString(System.String,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.String)"]

set_underline
Type: SystemBoolean

[Missing <param name="set_underline"/> documentation for "M:Rhino.Geometry.AnnotationBase.FormatRtfString(System.String,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.String)"]

clear_facename
Type: SystemBoolean

[Missing <param name="clear_facename"/> documentation for "M:Rhino.Geometry.AnnotationBase.FormatRtfString(System.String,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.String)"]

set_facename
Type: SystemBoolean

[Missing <param name="set_facename"/> documentation for "M:Rhino.Geometry.AnnotationBase.FormatRtfString(System.String,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.String)"]

facename
Type: SystemString

[Missing <param name="facename"/> documentation for "M:Rhino.Geometry.AnnotationBase.FormatRtfString(System.String,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Rhino.Geometry.AnnotationBase.FormatRtfString(System.String,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.String)"]

See Also