Rhino C++ API  8.10
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ON_SubDComponentAndPoint Class Reference

#include <opennurbs_subd.h>

Public Member Functions

 ON_SubDComponentAndPoint ()=default
 
 ON_SubDComponentAndPoint (const ON_SubDComponentAndPoint &)=default
 
 ~ON_SubDComponentAndPoint ()=default
 
const ON_SubDComponentPtr Component () const
 
ON_SubDComponentAndPointoperator= (const ON_SubDComponentAndPoint &)=default
 
const ON_3dPoint Point () const
 
void SetComponent (ON_SubDComponentPtr cptr)
 
void SetPoint (ON_3dPoint P)
 

Static Public Member Functions

static int CompareComponent (const ON_SubDComponentAndPoint *lhs, const ON_SubDComponentAndPoint *rhs)
 
static int CompareComponentAndDirection (const ON_SubDComponentAndPoint *lhs, const ON_SubDComponentAndPoint *rhs)
 
static int CompareComponentAndDirectionAndPoint (const ON_SubDComponentAndPoint *lhs, const ON_SubDComponentAndPoint *rhs)
 
static int CompareComponentAndPoint (const ON_SubDComponentAndPoint *lhs, const ON_SubDComponentAndPoint *rhs)
 
static int ComparePoint (const ON_SubDComponentAndPoint *lhs, const ON_SubDComponentAndPoint *rhs)
 
static const ON_SubDComponentAndPoint Create (const ON_SubDEdge *e, ON_3dPoint P)
 
static const ON_SubDComponentAndPoint Create (const ON_SubDEdgePtr eptr, ON_3dPoint P)
 
static const ON_SubDComponentAndPoint Create (const ON_SubDFace *f, ON_3dPoint P)
 
static const ON_SubDComponentAndPoint Create (const ON_SubDFacePtr fptr, ON_3dPoint P)
 
static const ON_SubDComponentAndPoint Create (const ON_SubDVertex *v, ON_3dPoint P)
 
static const ON_SubDComponentAndPoint Create (const ON_SubDVertexPtr vptr, ON_3dPoint P)
 
static const ON_SubDComponentAndPoint Create (ON_SubDComponentPtr cptr, ON_3dPoint P)
 

Public Attributes

ON_SubDComponentPtr m_cptr = ON_SubDComponentPtr::Null
 
ON_3dPoint m_P = ON_3dPoint::NanPoint
 

Static Public Attributes

static const ON_SubDComponentAndPoint NullAndNan
 
static const ON_SubDComponentAndPoint NullAndOrigin
 

Detailed Description

ON_SubDComponentAndPoint