GH_ArchivedUndoAction Class |
Namespace: Grasshopper.Kernel.Undo
The GH_ArchivedUndoAction type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_ArchivedUndoAction | Initializes a new instance of the GH_ArchivedUndoAction class |
Name | Description | |
---|---|---|
![]() | ExpiresDisplay |
Override this property if you want the Rhino viewport display to refresh upon undo completion.
(Inherited from GH_UndoAction.) |
![]() | ExpiresSolution |
Override this property if you want the Grasshopper solution to refresh upon undo completion.
(Inherited from GH_UndoAction.) |
![]() | State | (Inherited from GH_UndoAction.) |
Name | Description | |
---|---|---|
![]() | Deserialize |
Deserializes the obj from the local archive.
|
![]() | Internal_Redo | (Inherited from GH_UndoAction.) |
![]() | Internal_Undo | (Inherited from GH_UndoAction.) |
![]() | Read | (Overrides GH_UndoActionRead(GH_IReader).) |
![]() | Redo | (Inherited from GH_UndoAction.) |
![]() | Serialize |
Serializes the obj into the local archive.
|
![]() | SerializeToByteArray |
Serializes the obj into the local archive.
|
![]() | Undo | (Inherited from GH_UndoAction.) |
![]() | Write | (Overrides GH_UndoActionWrite(GH_IWriter).) |