GH_ResizableAttributesT Class |
Namespace: Grasshopper.Kernel.Attributes
public abstract class GH_ResizableAttributes<T> : GH_Attributes<T> where T : IGH_DocumentObject
The GH_ResizableAttributesT type exposes the following members.
Name | Description | |
---|---|---|
GH_ResizableAttributesT | Initializes a new instance of the GH_ResizableAttributesT class |
Name | Description | |
---|---|---|
Bounds |
Gets the rectangle that contains the active content of the attributes.
Typically the Contents determine the active area for menus, tooltips etc.
InputGrip |
Gets the input grip location for these attributes.
MaximumSize | ||
Owner |
Gets the type-safe owner object of these attributes. This property is identical to
Parent |
Gets or sets the parent attributes.
PathName |
Get a description of the location of these attributes
Pivot |
Gets or sets the pivot for these attributes. The pivot controls the general placement
Name | Description | |
---|---|---|
ExpireLayout |
Expires the entire layout of the attributes. When overridden,
InvalidateCanvas |
If the mouse location should cause a canvas invalidation then return true.
You only need to override this function if you draw objects that are dependant
IsMenuRegion |
Determines whether a point is available for context menu popups.
IsPickRegion(PointF) |
Determines whether a point is within the pickable region for this object.
IsPickRegion(RectangleF, GH_PickBox) |
Determines whether a rectangle is a valid pick region for this object.
IsTooltipRegion |
Determines whether a point is available for tooltip popups.
Layout |
Perform dedicated layout logic specific to this particular DocumentObject.
NewInstanceGuid(Guid) |
Generate a new instance GUID for the owner object. Do not use this overload
PerformLayout |
Recompute the layout for these attributes. This function is automatically called during
PrepareForRender |
This method will always be called exactly once prior to Render().
RenderIncomingWires(GH_Painter, IEnumerableIGH_Param, GH_ParamWireDisplay) |
Utility function for derived classes. This method draws all the wires going into the
RenderIncomingWires(GH_Painter, IEnumerableIGH_Param, IEnumerablePen) |
Utility function for derived classes. This method draws all the wires going into the
RenderToCanvas |
Render these attributes into a Canvas control. This function places calls to
RespondToMouseDown | (Overrides GH_AttributesTRespondToMouseDown(GH_Canvas, GH_CanvasMouseEvent).) | |
RespondToMouseMove | (Overrides GH_AttributesTRespondToMouseMove(GH_Canvas, GH_CanvasMouseEvent).) | |