GH_CanvasWireValidator Class |
Namespace: Grasshopper.GUI.Canvas
The GH_CanvasWireValidator type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_CanvasWireValidator | Initializes a new instance of the GH_CanvasWireValidator class |
Name | Description | |
---|---|---|
![]() | Canvas |
Gets the canvas this validator is associated with.
(Inherited from GH_CanvasValidator.) |
![]() | Document |
Gets the document (if it exists) that is currently loaded in the canvas.
(Inherited from GH_CanvasValidator.) |
![]() | WireDelegate |
Gets or sets the delegate to be invoked when a wire is created.
|
![]() | WireMotionText |
Gets or sets the text to draw at the wire interior.
|
![]() | WireSource |
Gets or sets the wire source filter.
|
![]() | WireSourceText |
Gets or sets the text to draw at the wire source location.
|
![]() | WireTarget |
Gets or sets the wire target filter.
|
![]() | WireTargetText |
Gets or sets the text to draw at the wire target location.
|
Name | Description | |
---|---|---|
![]() | AddedToCanvas | (Overrides GH_CanvasValidatorAddedToCanvas(GH_Canvas).) |
![]() | AppliesToDocument | (Overrides GH_CanvasValidatorAppliesToDocument(Guid).) |
![]() | CanAcceptObject | (Overrides GH_CanvasValidatorCanAcceptObject(Guid).) |
![]() | CanCreateObject | (Overrides GH_CanvasValidatorCanCreateObject(Guid, PointF).) |
![]() | CanCreateWire | (Overrides GH_CanvasValidatorCanCreateWire(IGH_Param, IGH_Param).) |
![]() | CanDeleteObject | (Overrides GH_CanvasValidatorCanDeleteObject(IGH_DocumentObject).) |
![]() | CanDeleteWire | (Overrides GH_CanvasValidatorCanDeleteWire(IGH_Param, IGH_Param).) |
![]() | CanDragObject | (Overrides GH_CanvasValidatorCanDragObject(IGH_DocumentObject, PointF).) |
![]() | CanNavigateCanvas | (Inherited from GH_CanvasValidator.) |
![]() | CanShowCanvasMenu | (Overrides GH_CanvasValidatorCanShowCanvasMenu(PointF).) |
![]() | CanShowComponentSearchBox | (Overrides GH_CanvasValidatorCanShowComponentSearchBox(PointF).) |
![]() | CanShowObjectMenu | (Inherited from GH_CanvasValidator.) |
![]() | RemovedFromCanvas | (Overrides GH_CanvasValidatorRemovedFromCanvas(GH_Canvas).) |