GH_CanvasValidator Class |
Namespace: Grasshopper.GUI.Canvas
The GH_CanvasValidator type exposes the following members.
Name | Description | |
---|---|---|
![]() | GH_CanvasValidator | Initializes a new instance of the GH_CanvasValidator class |
Name | Description | |
---|---|---|
![]() | Canvas |
Gets the canvas this validator is associated with.
|
![]() | Document |
Gets the document (if it exists) that is currently loaded in the canvas.
|
Name | Description | |
---|---|---|
![]() | AddedToCanvas |
Override this method if you want to be informed when this validator gets assigned to a canvas.
But *always* call the base class method.
|
![]() | AppliesToDocument | |
![]() | CanAcceptObject | |
![]() | CanCreateObject | |
![]() | CanCreateWire | |
![]() | CanDeleteObject | |
![]() | CanDeleteWire | |
![]() | CanDragObject | |
![]() | CanNavigateCanvas | |
![]() | CanShowCanvasMenu | |
![]() | CanShowComponentSearchBox | |
![]() | CanShowObjectMenu | |
![]() | RemovedFromCanvas |
Override this method if you want to be informed when this validator gets removed from a canvas.
But *always* call the base class method.
|