Param_Leader Properties |
The Param_Leader type exposes the following members.
Name | Description | |
---|---|---|
Attributes |
Gets or sets the attributes that are associated with this object.
ClippingBox | ||
HasProxySources |
Gets a value indicating whether or not this parameter maintains proxy sources.
Proxy sources are used during file IO, when actual sources might not be available yet.
Hidden | ||
IconCapableUI |
By default the NickName menu item supports the Icon Mode override toggle.
If your UI is not capable of displaying icons, then override this property
IsBakeCapable | ||
Keywords |
Gets a list of additional keywords that describe the object. Typically this list is empty but you
MutableNickName |
Gets or sets a value that enables Nick name changes through the menu.
Obsolete |
Gets whether this object is obsolete. Default implementation returns true if
the class name contains the string "OBSOLETE" or if this class has been decorated with the
Optional |
Gets or sets whether or not this parameter is considered optional by the owner component.
PersistentData |
Gets the persistent data stored in this parameter.
If you modify the persistent data, be sure to call the:
OnObjectChanged(GH_ObjectEventType.PersistentData)
ProxySourceCount |
Gets the number of proxy sources for this parameter.
Proxy sources are used during file IO, when actual sources might not be available yet.
Recipients |
Gets a list of all the recipients of this parameter.
I.e. a recipient has this parameter as one of the sources.
The Recipient list is maintained by the parameter,
Sources |
Gets a list of source parameters. Do not modify this list,
if you wish to add or remove sources, use dedicated functions
StateTags |
Gets all the StateTags that are associated with this parameter.
TypeName |
Calls TypeName() on the first instance of T it can find.
WireDisplay |
Gets or sets the wire display style for this parameter.