Click or drag to resize

IRhinoAccountsManager Interface

Performs various Rhino Accounts-related tasks.

Namespace:  Rhino.Runtime.RhinoAccounts
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public interface IRhinoAccountsManager

The IRhinoAccountsManager type exposes the following members.

Methods
  NameDescription
Public methodExecuteProtectedCode
Any synchronous method in the IRhinoAccountsManager class must be executed within the function passed to this method, or an InvalidOperationException will be thrown.
Public methodExecuteProtectedCodeAsync
Any asynchronous method in the IRhinoAccountsManager class must be executed within the function passed to this method, or an InvalidOperationException will be thrown.
Public methodGetAuthTokensAsync(String, String, SecretKey, CancellationToken)
Asynchronously retrieves auth tokens with the given criteria from the Rhino Accounts server.
Public methodGetAuthTokensAsync(String, String, IEnumerableString, String, NullableInt32, Boolean, IProgressRhinoAccoountsProgressInfo, SecretKey, CancellationToken)
Asynchronously retrieves auth tokens with the given criteria from the Rhino Accounts server.
Public methodRevokeAuthTokenAsync
Invalidates/revokes an IOAuth2Token object from the Rhino Accounts server.
Public methodTryGetAuthTokens(String, SecretKey)
Attempts to return cached auth tokens that match the given criteria if any have been stored in cache.
Public methodTryGetAuthTokens(String, IEnumerableString, SecretKey)
Attempts to return cached auth tokens that match the given criteria if any have been stored in cache.
Public methodUpdateOpenIDConnectTokenAsync
Updates an OpenID Connect token so that it contains the latest user information by contacting the Rhino Account's server userinfo endpoint using a compatible O
Top
See Also