IRhinoAccountsManagerExecuteProtectedCode Method |
Namespace:
Rhino.Runtime.RhinoAccounts
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax void ExecuteProtectedCode(
Action<SecretKey> protectedCode
)
Sub ExecuteProtectedCode (
protectedCode As Action(Of SecretKey)
)
Parameters
- protectedCode
- Type: SystemActionSecretKey
A function returning an awaitable task that has a SecretKey passed to it. You will need to pass this
secret key to any method you wish to call within IRhinoAccountsManager.
Exceptions Remarks The code within the function passed must be kept as breif as possible for performance and security reasons.
See Also