Click or drag to resize

IOAuth2Token Interface

Represents an OAuth2 Token that can be used for authorization purposes.

Namespace:  Rhino.Runtime.RhinoAccounts
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public interface IOAuth2Token

The IOAuth2Token type exposes the following members.

Properties
  NameDescription
Public propertyExp
The expiration of the token. Expired tokens will be considered invalid by the Rhino Accounts server.
Public propertyIsExpired
true if the token is expired; false otherwise.
Public propertyRawToken
The raw token that can be passed to various servers for authorization.
Public propertyScope
The scope of the token.
Top
See Also