Click or drag to resize

StdVectorFloat Class

Wrapper for ON_SimpleArray<float>. If you are not writing C++ code then this class is not for you.
Inheritance Hierarchy
SystemObject
  Rhino.Runtime.InteropWrappersStdVectorFloat

Namespace:  Rhino.Runtime.InteropWrappers
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class StdVectorFloat : IDisposable

The StdVectorFloat type exposes the following members.

Constructors
  NameDescription
Public methodStdVectorFloat
Initializes a new StdVectorFloat class.
Public methodStdVectorFloat(IEnumerableSingle)
Initializes a new SimpleArrayFloat class
Public methodStdVectorFloat(StdVectorFloat)
Initializes a new StdVectorFloat with the contents of another SimpleArrayFloat.
Public methodStdVectorFloat(UInt64)
Initializes a new StdVectorFloat class. Initial size of the array - all values are set to zero.
Top
Properties
  NameDescription
Public propertyCount
Gets the amount of elements in this array.
Top
Methods
  NameDescription
Public methodConstPointer
Gets the constant (immutable) pointer of this array.
Public methodCopyTo
Copies the contents of a StdVectorFloat into another SimpleArrayFloat.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodMemory
Return the raw data.
Public methodNonConstPointer
Gets the non-constant pointer (for modification) of this array.
Public methodToArray
Returns the managed counterpart of the unmanaged array.
Top
See Also