Click or drag to resize

SimpleArrayFloat Class

Wrapper for ON_SimpleArray<float>. If you are not writing C++ code then this class is not for you.
Inheritance Hierarchy
SystemObject
  Rhino.Runtime.InteropWrappersSimpleArrayFloat

Namespace:  Rhino.Runtime.InteropWrappers
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SimpleArrayFloat : IDisposable

The SimpleArrayFloat type exposes the following members.

Constructors
  NameDescription
Public methodSimpleArrayFloat
Initializes a new SimpleArrayFloat class.
Public methodSimpleArrayFloat(IEnumerableSingle)
Initializes a new SimpleArrayFloat class
Public methodSimpleArrayFloat(Int32)
Initializes a new SimpleArrayFloat class. Initial size of the array - all values are set to zero.
Public methodSimpleArrayFloat(SimpleArrayFloat)
Initializes a new SimpleArrayFloat with the contents of another SimpleArrayFloat.
Top
Properties
  NameDescription
Public propertyCount
Gets the amount of elements in this array.
Top
Methods
  NameDescription
Public methodArray
Return the raw data.
Public methodConstPointer
Gets the constant (immutable) pointer of this array.
Public methodCopyTo
Copies the contents of a SimpleArrayFloat into another SimpleArrayFloat.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodNonConstPointer
Gets the non-constant pointer (for modification) of this array.
Public methodToArray
Returns the managed counterpart of the unmanaged array.
Top
See Also