Click or drag to resize

SimpleArraySubDPointer Class

Wrapper for a C++ ON_SimpleArray<ON_SubD*> or ON_SimpleArray<constant ON_SubD*> If you are not writing C++ code then this class is not for you.
Inheritance Hierarchy
SystemObject
  Rhino.Runtime.InteropWrappersSimpleArraySubDPointer

Namespace:  Rhino.Runtime.InteropWrappers
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SimpleArraySubDPointer : IDisposable

The SimpleArraySubDPointer type exposes the following members.

Constructors
  NameDescription
Public methodSimpleArraySubDPointer
Initializes a new SimpleArraySubDPointer instance.
Top
Properties
  NameDescription
Public propertyCount
Gets the amount of subds in this array.
Top
Methods
  NameDescription
Public methodAdd
Adds a subd to the list.
Public methodConstPointer
Gets the constant (immutable) pointer of this array.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the SimpleArraySubDPointer and optionally releases the managed resources
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodNonConstPointer
Gets the non-constant pointer (for modification) of this array.
Public methodToNonConstArray
Copies the unmanaged array to a managed counterpart.
Top
See Also