SimpleArrayGuid Class |
Namespace: Rhino.Runtime.InteropWrappers
The SimpleArrayGuid type exposes the following members.
Name | Description | |
---|---|---|
SimpleArrayGuid |
Initializes a new SimpleArrayGuid class.
| |
SimpleArrayGuid(IEnumerableGuid) |
Initializes a new SimpleArrayGuid class
|
Name | Description | |
---|---|---|
Append |
Appends a new Guid at the end of this array.
| |
ConstPointer |
Gets the constant (immutable) pointer of this array.
| |
Dispose |
Actively reclaims unmanaged resources that this instance uses.
| |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Finalize |
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.) | |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) | |
NonConstPointer |
Gets the non-constant pointer (for modification) of this array.
| |
ToArray |
Returns the managed counterpart of the unmanaged array.
| |
ToString | Returns a string that represents the current object. (Inherited from Object.) |