Click or drag to resize

SimpleArrayArrayPoint3d Class

Wrapper for ON_SimpleArray<ON_PolyLine*>, ON_SimpleArray<ON_3dPointArray*> If you are not writing C++ code then this class is not for you.
Inheritance Hierarchy
SystemObject
  Rhino.Runtime.InteropWrappersSimpleArrayArrayPoint3d

Namespace:  Rhino.Runtime.InteropWrappers
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SimpleArrayArrayPoint3d : IDisposable

The SimpleArrayArrayPoint3d type exposes the following members.

Constructors
  NameDescription
Public methodSimpleArrayArrayPoint3d
Initializes a new empty SimpleArrayArrayPoint3d instance.
Top
Properties
  NameDescription
Public propertyCount
Gets the amount of polylines in this array.
Public propertyItem
Gets a point in a polyline.
Top
Methods
  NameDescription
Public methodConstPointer
Gets the constant (immutable) pointer of this array.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodNonConstPointer
Gets the non-constant pointer (for modification) of this array.
Public methodPointCountAt
Gets the amount of points in a polyline.
Public methodPolylineAt
Gets a polyline at an index.
Top
See Also