Click or drag to resize

ClassArrayOnObjRef Class

Represents a wrapper to an unmanaged "array" (list) of ON_ObjRef instances.

Wrapper for a C++ ON_ClassArray of ON_ObjRef

Inheritance Hierarchy
SystemObject
  Rhino.Runtime.InteropWrappersClassArrayOnObjRef

Namespace:  Rhino.Runtime.InteropWrappers
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class ClassArrayOnObjRef : IDisposable

The ClassArrayOnObjRef type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyCount
Gets the number of ObjRef instances in this array.
Top
Methods
  NameDescription
Public methodAdd
Adds an ObjRef to the list.
Public methodConstPointer
Gets the constant (immutable) pointer of this array.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodNonConstPointer
Gets the non-constant pointer (for modification) of this array.
Public methodToNonConstArray
Copies the unmanaged array to a managed counterpart.
Public methodToNonConstArray(RhinoDoc)
Copies the unmanaged array to a managed counterpart.
Top
See Also