RhinoCore Class |
Namespace: Rhino.Runtime.InProcess
The RhinoCore type exposes the following members.
Name | Description | |
---|---|---|
![]() | RhinoCore |
Initializes a new instance of the RhinoCore class.
|
![]() | RhinoCore(String) |
Initializes a new instance of the RhinoCore class.
|
![]() | RhinoCore(String, WindowStyle) |
Initializes a new instance of the RhinoCore class.
|
![]() | RhinoCore(String, WindowStyle, IntPtr) |
Initializes a new instance of the RhinoCore class.
|
Name | Description | |
---|---|---|
![]() | Dispose |
IDisposable implementation
|
![]() | DoEvents |
If a Rhino owned window is active processes all Windows messages currently in the message queue.
|
![]() | DoIdle |
Processes all Rhino Idle tasks.
|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | Finalize |
IDisposable implementation
(Overrides ObjectFinalize.) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | InvokeInHostContext(Action) |
Invokes action in Host context
|
![]() | InvokeInHostContextT(FuncT) |
Invokes function in Host context
|
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | RaiseIdle |
Raises the Idle event.
|
![]() | Run |
Runs RhinoApp Message loop
|
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |