Click or drag to resize

RhinoCoreInvokeInHostContextT Method (FuncT)

Invokes function in Host context

Namespace:  Rhino.Runtime.InProcess
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax
public T InvokeInHostContext<T>(
	Func<T> func
)

Parameters

func
Type: SystemFuncT

[Missing <param name="func"/> documentation for "M:Rhino.Runtime.InProcess.RhinoCore.InvokeInHostContext``1(System.Func{``0})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Rhino.Runtime.InProcess.RhinoCore.InvokeInHostContext``1(System.Func{``0})"]

Return Value

Type: T
Returns argument function return value.
See Also