Click or drag to resize

RenderMeshProvider Class

A RenderMeshProvider delivers custom render primitives (in the form of RenderMeshes). Derive a public class from this with a public constructor, and this primitive provider will be added to the RDK forming a collection of providers. Each RenderMeshProvider::HasCustomRenderMeshes will be called and if it returns true, a call to RenderMeshes will be made. It is up to the provider to cache its own primitives - the IRenderMeshes::ProviderTracking class is provided for that. A provider may optionally return a collection of non-object Ids that it will provide custom render primitives for. An example of this is Grasshopper, which which will typically return a collection of the Ids of each CustomPreview component. Override this class if you are a plug-in developer intending to supply a custom set of primitives for a given object, or objectId. Examples of IRenderMeshProviders are CurvePiping, EdgeSoftening, Displacement, Shutlining, Grasshopper's CustomPreview component.
Inheritance Hierarchy
SystemObject
  Rhino.Render.CustomRenderMeshesRenderMeshProvider

Namespace:  Rhino.Render.CustomRenderMeshes
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class RenderMeshProvider : IDisposable

The RenderMeshProvider type exposes the following members.

Constructors
  NameDescription
Protected methodRenderMeshProvider
Initializes a new instance of the RenderMeshProvider class
Top
Properties
  NameDescription
Public propertyName
The localized name of the provider for UI display.
Public propertyNonObjectIds
A provider may optionally return a collection of non-object Ids that it will provide custom render primitives for. An example of this is Grasshopper, which which will typically return a collection of the Ids of each CustomPreview component.
Public propertyProviderId
The localized name of the provider for UI display.
Top
Methods
  NameDescription
Public methodDispose
Dispose method
Protected methodDispose(Boolean)
Dispose method. Note that you should only ever call Dispose if you explicitly registered this RenderMeshProvider using RegisterProvider If this provider was created using automatic registration, the Dispose function will thrown an exception.
Protected methodFinalize
Finalizer to ensure correctly implemented dispose pattern.
(Overrides ObjectFinalize.)
Public methodGetParameter
Runtime access to specific parameters on for a given objectId relating to this primitive provider.
Public methodHasCustomRenderMeshes
Determine if custom render primitives will be supplied for a particular object.
Public methodProgress
Provides details on the progress of custom render meshes for a document or collection of objects
Public methodStatic memberProgressForAll
Returns a complete list of progress reports for all providers for either the document or a collection of objects
Public methodStatic memberRegisterProvider
Register RenderMeshProvider without relying on the auto-plug-in registration.
Public methodStatic memberRegisterProviders(PlugIn)
Register RenderMeshProviders without relying on the auto-plug-in registration
Public methodStatic memberRegisterProviders(Assembly, PlugIn)
Register RenderMeshProviders without relying on the auto-plug-in registration
Public methodRenderMeshes
Returns a complete set of custom render primitives for a given ObjectId.
Public methodSetParameter
Top
Fields
  NameDescription
Protected fieldm_disposed
m_disposed available for sub-classes to check.
Top
See Also