Click or drag to resize

RenderMeshProvider Methods

The RenderMeshProvider type exposes the following members.

Methods
  NameDescription
Public methodDispose
Dispose method
Protected methodDispose(Boolean)
Dispose method. Note that you should only ever call Dispose if you explicitly registered this RenderMeshProvider using RegisterProvider If this provider was created using automatic registration, the Dispose function will thrown an exception.
Protected methodFinalize
Finalizer to ensure correctly implemented dispose pattern.
(Overrides ObjectFinalize.)
Public methodGetParameter
Runtime access to specific parameters on for a given objectId relating to this primitive provider.
Public methodHasCustomRenderMeshes
Determine if custom render primitives will be supplied for a particular object.
Public methodProgress
Provides details on the progress of custom render meshes for a document or collection of objects
Public methodStatic memberProgressForAll
Returns a complete list of progress reports for all providers for either the document or a collection of objects
Public methodStatic memberRegisterProvider
Register RenderMeshProvider without relying on the auto-plug-in registration.
Public methodStatic memberRegisterProviders(PlugIn)
Register RenderMeshProviders without relying on the auto-plug-in registration
Public methodStatic memberRegisterProviders(Assembly, PlugIn)
Register RenderMeshProviders without relying on the auto-plug-in registration
Public methodRenderMeshes
Returns a complete set of custom render primitives for a given ObjectId.
Public methodSetParameter
Top
See Also