Click or drag to resize

Instance Class

The core of the custom render primitive delivery system - and instance defines a single mesh. Each instance has a shared mesh and a transform, along with a material, mapping channels (at the mesh and instance level).
Inheritance Hierarchy
SystemObject
  Rhino.Render.CustomRenderMeshesInstance

Namespace:  Rhino.Render.CustomRenderMeshes
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class Instance : IDisposable

The Instance type exposes the following members.

Constructors
  NameDescription
Public methodInstance
Construct a new Instance object
Top
Properties
  NameDescription
Public propertyIsForcedMaterial
The material for this instance should override any display mode materials.
Public propertyIsRequestingPlugInDependent
If this instance will change depending on the requesting plug-in.
Public propertyIsViewDependent
If this instance will change depending on the view direction.
Public propertyMaterial
The material for this instance.
Public propertyMesh
Returns the mesh associated with this geometry. Note that this function will always return a mesh even if the type is not a mesh...so you can always call this function without checking the type to give you the mesh. It's more efficient to use the primitive directly of course...but if you don't support it...
Public propertyTransform
The transform for this instance. Transform the geometry by this to set its final location in world space.
Top
Methods
  NameDescription
Public methodDispose
Dispose method
Protected methodDispose(Boolean)
Dispose method.
Protected methodFinalize
Finalizer to ensure correctly implemented dispose pattern.
(Overrides ObjectFinalize.)
Top
See Also