Click or drag to resize

Instance Properties

The Instance type exposes the following members.

Properties
  NameDescription
Public propertyIsForcedMaterial
The material for this instance should override any display mode materials.
Public propertyIsRequestingPlugInDependent
If this instance will change depending on the requesting plug-in.
Public propertyIsViewDependent
If this instance will change depending on the view direction.
Public propertyMaterial
The material for this instance.
Public propertyMesh
Returns the mesh associated with this geometry. Note that this function will always return a mesh even if the type is not a mesh...so you can always call this function without checking the type to give you the mesh. It's more efficient to use the primitive directly of course...but if you don't support it...
Public propertyTransform
The transform for this instance. Transform the geometry by this to set its final location in world space.
Top
See Also