Click or drag to resize

PlugInInfo Class

Contains detailed information about a Rhino plug-in.
Inheritance Hierarchy
SystemObject
  Rhino.PlugInsPlugInInfo

Namespace:  Rhino.PlugIns
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class PlugInInfo

The PlugInInfo type exposes the following members.

Properties
  NameDescription
Public propertyAddress
Returns the address of the organization or company that created the plug-in.
Public propertyCommandNames
Returns a plug-in's English command names.
Public propertyCountry
Returns the country of the organization or company that created the plug-in.
Public propertyDescription
Returns the plug-in's description.
Public propertyEmail
Returns the email address of the organization or company that created the plug-in.
Public propertyFax
Returns the fax number of the organization or company that created the plug-in.
Public propertyFileName
Returns the plug-in's file name.
Public propertyFileTypeDescriptions
Returns the description of supported file types for file import and file export plug-in.
Public propertyFileTypeExtensions
Returns the file types extensions supported for file import and file export plug-in.
Public propertyId
Returns the plug-in's Id.
Public propertyIsDotNet
Returns true if the plug-in is based on .NET, false otherwise.
Public propertyIsLoaded
Returns true if the plug-in is loaded, false otherwise.
Public propertyName
Returns the plug-in's name.
Public propertyOrganization
Returns the organization or company that created the plug-in.
Public propertyPhone
Returns the phone number of the organization or company that created the plug-in.
Public propertyPlugInLoadTime
Returns the plug-in's load time.
Public propertyPlugInType
Returns the plug-in type.
Public propertyRegistryPath
Returns the plug-in's Windows Registry path.
Public propertyShipsWithRhino
Returns true if the plug-in ships with Rhino, false otherwise.
Public propertyUpdateUrl
Returns the web site, or URL, were an updated version of the plug-in can be found.
Public propertyVersion
Returns the plug-in's version.
Public propertyWebSite
Returns the web site, or URL, of the organization or company that created the plug-in.
Top
Methods
  NameDescription
Public methodIcon
Returns the plug-in's icon in bitmap form.
Public methodIsLoadProtected
Returns the load protection state for a plug-in
Top
See Also