LicenseData Class |
Namespace: Rhino.PlugIns
The LicenseData type exposes the following members.
Name | Description | |
---|---|---|
LicenseData |
Public constructor.
| |
LicenseData(String, String, String) |
Public constructor
| |
LicenseData(String, String, String, LicenseBuildType) |
Public constructor
| |
LicenseData(String, String, String, LicenseBuildType, Int32) |
Public constructor
| |
LicenseData(String, String, String, LicenseBuildType, Int32, NullableDateTime) |
Public constructor
| |
LicenseData(String, String, String, LicenseBuildType, Int32, NullableDateTime, Icon) |
Public constructor
| |
LicenseData(String, String, String, LicenseBuildType, Int32, NullableDateTime, Icon, Boolean, Boolean) |
Public constructor
|
Name | Description | |
---|---|---|
BuildType |
The build of the product that this license work with.
When your product requests a license from the Zoo, it
will specify one of these build types.
| |
DateToExpire |
The date and time the license is set to expire.
This is provided by the plug in that validated the license.
This time value should be in Coordinated Universal Time (UTC).
| |
ErrorMessage |
Error message set by calls to callback functions
| |
IsUpgradeFromPreviousVersion |
Set to true if this license requires a previous version license to be entered.
Caller must also pass VerifyPreviousVersionLicenseDelegate to GetLicense/AskUserForLicense.
| |
LicenseCount |
The number of instances supported by this license.
This is provided by the plug in that validated the license.
| |
LicenseExpires | ||
LicenseTitle |
The title of the license.
This is provided by the plug-in that validated the license.
(e.g. "Rhinoceros 6.0 Commercial")
| |
ProductIcon |
The product's icon. This will displayed in the "license"
page in the Options dialog. Note, this can be null.
Note, LicenseData creates it's own copy of the icon.
| |
ProductLicense |
The actual product license.
This is provided by the plug-in that validated the license.
| |
RequiresOnlineValidation |
Set to true if this license requires online validation.
Caller must also pass VerifyOnlineValidationCodeDelegate to GetLicense/AskUserForLicense
| |
SerialNumber |
The "for display only" product license.
This is provided by the plug-in that validated the license.
|
Name | Description | |
---|---|---|
Dispose | Releases all resources used by the LicenseData | |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) | |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
IsNotValid |
Indicates whether a LicenseData object is either null or invalid.
| |
IsValid |
Public validator.
| |
IsValid(Boolean) | ||
IsValid(LicenseData) |
Indicates whether a LicenseData object is not null and valid.
| |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) | |
ToString | Returns a string that represents the current object. (Inherited from Object.) |