Click or drag to resize

LicenseData Properties

The LicenseData type exposes the following members.

Properties
  NameDescription
Public propertyBuildType
The build of the product that this license work with. When your product requests a license from the Zoo, it will specify one of these build types.
Public propertyDateToExpire
The date and time the license is set to expire. This is provided by the plug in that validated the license. This time value should be in Coordinated Universal Time (UTC).
Public propertyErrorMessage
Error message set by calls to callback functions
Public propertyIsUpgradeFromPreviousVersion
Set to true if this license requires a previous version license to be entered. Caller must also pass VerifyPreviousVersionLicenseDelegate to GetLicense/AskUserForLicense.
Public propertyLicenseCount
The number of instances supported by this license. This is provided by the plug in that validated the license.
Public propertyLicenseExpires
Public propertyLicenseTitle
The title of the license. This is provided by the plug-in that validated the license. (e.g. "Rhinoceros 6.0 Commercial")
Public propertyProductIcon
The product's icon. This will displayed in the "license" page in the Options dialog. Note, this can be null. Note, LicenseData creates it's own copy of the icon.
Public propertyProductLicense
The actual product license. This is provided by the plug-in that validated the license.
Public propertyRequiresOnlineValidation
Set to true if this license requires online validation. Caller must also pass VerifyOnlineValidationCodeDelegate to GetLicense/AskUserForLicense
Public propertySerialNumber
The "for display only" product license. This is provided by the plug-in that validated the license.
Top
See Also