Click or drag to resize

PersistentSettingsConverter Class

Used to convert string to string lists and string dictionaries and back to strings again.
Inheritance Hierarchy
SystemObject
  RhinoPersistentSettingsConverter

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class PersistentSettingsConverter

The PersistentSettingsConverter type exposes the following members.

Methods
  NameDescription
Public methodStatic memberIsStringDictionary
Determines if the string value is formatted as a key value pair string list.
Public methodStatic memberIsStringList
Determines if the string value is formatted as a string list.
Public methodStatic memberToString(Double)
Converts a double value to a string.
Public methodStatic memberToString(KeyValuePairString, String)
Converts a key value string pair array to a properly formatted string dictionary XML string.
Public methodStatic memberToString(String)
Converts a string array to a properly formatted string list XML string.
Public methodStatic memberTryParseDouble
Converts the string representation of a number to its double-precision floating-point number equivalent. A return value indicates whether the conversion succeeded or failed. system culture.
Public methodStatic memberTryParseEnum(Type, String, Int32)
Converts an enumerated value name to its integer equivalent.
Public methodStatic memberTryParseEnum(Type, String, String)
Converts an enumerated value string (integer as string) to a enumerated value name.
Public methodStatic memberTryParseStringDictionary
Attempts to convert a string to a key value string pair array.
Public methodStatic memberTryParseStringList
Attempts to convert a string to a string value list.
Top
See Also