Click or drag to resize

PersistentSettingsConverterTryParseEnum Method (Type, String, Int32)

Converts an enumerated value name to its integer equivalent.

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static bool TryParseEnum(
	Type type,
	string enumValueName,
	out int value
)

Parameters

type
Type: SystemType
The enumerated type
enumValueName
Type: SystemString
Enumerated value name as string
value
Type: SystemInt32
Output value, will get set to -1 on error

Return Value

Type: Boolean
Returns true if the successfully converted or false if not.
See Also