Click or drag to resize

NodeInCodeTable Class

Permits rapid access to references to all Grasshopper functions.
Inheritance Hierarchy

Namespace:  Rhino.NodeInCode
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class NodeInCodeTable : DynamicObject

The NodeInCodeTable type exposes the following members.

Constructors
  NameDescription
Public methodNodeInCodeTable
Instantiates the table. Users of RhinoCommon do not typically need to call this constructor.
Top
Properties
  NameDescription
Public propertyCount
Returns the amount of items in this table.
Top
Methods
  NameDescription
Public methodAdd
Adds, or replaces a new instance of component function information.
Public methodGetDynamicMemberNames
Returns all additional names in the table.
(Overrides DynamicObjectGetDynamicMemberNames.)
Public methodGetDynamicMembers
Returns component info for all additional names in the table.
Public methodTryGetIndex
Gets the ComponentFunctionInfo at
(Overrides DynamicObjectTryGetIndex(GetIndexBinder, Object, Object).)
Public methodTryGetMember
Dynamically binds the table to property-like access via its item names.
(Overrides DynamicObjectTryGetMember(GetMemberBinder, Object).)
Public methodTryInvokeMember
Dynamically invokes a member of the table.
(Overrides DynamicObjectTryInvokeMember(InvokeMemberBinder, Object, Object).)
Top
See Also