Click or drag to resize

BrepVertexList Class

Provides access to all the Vertices in a Brep object
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.CollectionsBrepVertexList

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class BrepVertexList : IEnumerable<BrepVertex>, 
	IEnumerable

The BrepVertexList type exposes the following members.

Properties
  NameDescription
Public propertyCount
Gets the number of brep vertices.
Public propertyItem
Gets the BrepVertex at the given index. The index must be valid or an IndexOutOfRangeException will be thrown.
Top
Methods
  NameDescription
Public methodAdd
Create and add a new vertex to this list
Public methodAdd(Point3d, Double)
Create and add a new vertex to this list
Public methodAddPointOnFace
Adds a new point on face to the brep
Public methodGetEnumerator
Gets an enumerator that visits all surfaces.
Top
See Also