Click or drag to resize

BrepLoopList Class

Provides access to all the Loops in a Brep object.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.CollectionsBrepLoopList

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class BrepLoopList : IEnumerable<BrepLoop>, 
	IEnumerable

The BrepLoopList type exposes the following members.

Properties
  NameDescription
Public propertyCount
Gets the number of brep loops.
Public propertyItem
Gets the BrepLoop at the given index. The index must be valid or an IndexOutOfRangeException will be thrown.
Top
Methods
  NameDescription
Public methodAdd(BrepLoopType)
Create a new empty boundary loop. The new loop will not be part of a face and will not include any trim curves.
Public methodAdd(BrepLoopType, BrepFace)
Create a new boundary loop on a face. After you get this BrepLoop, you still need to create the vertices, edges, and trims that define the loop.
Public methodAddOuterLoop
Create a new outer boundary loop that runs along the sides of the face's surface. All the necessary trims, edges, and vertices are created and added to the brep.
Public methodAddPlanarFaceLoop
Add a planar trimming loop to a planar face
Public methodGetEnumerator
Gets an enumerator that visits all edges.
Top
See Also