Click or drag to resize

BrepLoopList Methods

The BrepLoopList type exposes the following members.

Methods
  NameDescription
Public methodAdd(BrepLoopType)
Create a new empty boundary loop. The new loop will not be part of a face and will not include any trim curves.
Public methodAdd(BrepLoopType, BrepFace)
Create a new boundary loop on a face. After you get this BrepLoop, you still need to create the vertices, edges, and trims that define the loop.
Public methodAddOuterLoop
Create a new outer boundary loop that runs along the sides of the face's surface. All the necessary trims, edges, and vertices are created and added to the brep.
Public methodAddPlanarFaceLoop
Add a planar trimming loop to a planar face
Public methodGetEnumerator
Gets an enumerator that visits all edges.
Top
See Also