RuntimeDocumentDataTable Class |
Namespace: Rhino.DocObjects.Tables
The RuntimeDocumentDataTable type exposes the following members.
Name | Description | |
---|---|---|
Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from DictionaryObject, Object.) | |
Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from DictionaryObject, Object.) | |
Document | ||
Item | Gets or sets the value associated with the specified key. (Inherited from DictionaryObject, Object.) | |
Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from DictionaryObject, Object.) | |
Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from DictionaryObject, Object.) |
Name | Description | |
---|---|---|
Add | Adds the specified key and value to the dictionary. (Inherited from DictionaryObject, Object.) | |
Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from DictionaryObject, Object.) | |
ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from DictionaryObject, Object.) | |
ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from DictionaryObject, Object.) | |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from DictionaryObject, Object.) | |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from DictionaryObject, Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
GetValueT |
Checks the dictionary for the specified key, if found and the value is not
null then the value is returned. If the key is not found or its value
is null then newT(Document) is called to create a new value instance which
is put in the dictionary and returned.
| |
OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from DictionaryObject, Object.) | |
Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from DictionaryObject, Object.) | |
ToString | Returns a string that represents the current object. (Inherited from Object.) | |
TryGetValue(TKey, TValue) | Gets the value associated with the specified key. (Inherited from DictionaryObject, Object.) | |
TryGetValueT(Object) |
Check dictionary for value and return it properly cast if
found.
|