Click or drag to resize

RuntimeDocumentDataTableTryGetValueT Method (Object)

Check dictionary for value and return it properly cast if found.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.15
Syntax
public T TryGetValue<T>(
	Object key
)
where T : class

Parameters

key
Type: SystemObject
Key to search for.

Type Parameters

T
Class type created as necessary and returned.

Return Value

Type: T
Returns the document specific instance of type T using the specified dictionary key or null if not found.
See Also