Click or drag to resize

CustomObjectGrips Class

[Missing <summary> documentation for "T:Rhino.DocObjects.Custom.CustomObjectGrips"]

Inheritance Hierarchy
SystemObject
  Rhino.DocObjects.CustomCustomObjectGrips

Namespace:  Rhino.DocObjects.Custom
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class CustomObjectGrips : IDisposable

The CustomObjectGrips type exposes the following members.

Constructors
  NameDescription
Protected methodCustomObjectGrips
Initializes a new instance of the CustomObjectGrips class
Top
Properties
  NameDescription
Public propertyGripCount
Public propertyGripsMoved
If GripsMoved is true if some of the grips have ever been moved GripObject.NewLocation() sets GripsMoved=true.
Public propertyNewLocation
true if some of the grips have been moved. GripObject.NewLocation() sets NewLocation=true. Derived classes can set NewLocation to false after updating temporary display information.
Public propertyOwnerObject
Owner of the grips.
Top
Methods
  NameDescription
Protected methodAddGrip
Public methodDispose
Releases all resources used by the CustomObjectGrips
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the CustomObjectGrips and optionally releases the managed resources
Public methodStatic memberDragging
Determines if grips are currently being dragged.
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGrip
Protected methodNeighborGrip
Get neighbors.
Protected methodNewGeometry
If the grips control just one object, then override NewGeometry(). When NewGeometry() is called, return new geometry calculated from the current grip locations. This happens once at the end of a grip drag.
Protected methodNurbsSurface
If the grips control a NURBS surface, this returns a pointer to that surface. You can look at but you must NEVER change this surface.
Protected methodNurbsSurfaceGrip
If the grips are control points of a NURBS surface, then this gets the index of the grip that controls the (i,j)-th CV.
Protected methodOnDraw
Draws the grips. In your implementation, override this if you need to draw dynamic elements and then call this base implementation to draw the grips themselves.
Protected methodOnReset
Resets location of all grips to original spots and cleans up stuff that was created by dynamic dragging. This is required when dragging is canceled or in the Copy command when grips are "copied". The override should clean up dynamic workspace stuff.
Protected methodOnResetMeshes
Just before Rhino turns off object grips, it calls this function. If grips have modified any display meshes, they must override this function and restore the meshes to their original states.
Protected methodOnUpdateMesh
Just before Rhino shades an object with grips on, it calls this method to update the display meshes. Grips that modify surface or mesh objects must override this function and modify the display meshes here.
Public methodStatic memberRegisterGripsEnabler
Top
See Also