Click or drag to resize

CustomObjectGrips Methods

The CustomObjectGrips type exposes the following members.

Methods
  NameDescription
Protected methodAddGrip
Public methodDispose
Protected methodDispose(Boolean)
Public methodStatic memberDragging
Determines if grips are currently being dragged.
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGrip
Protected methodNeighborGrip
Get neighbors.
Protected methodNewGeometry
If the grips control just one object, then override NewGeometry(). When NewGeometry() is called, return new geometry calculated from the current grip locations. This happens once at the end of a grip drag.
Protected methodNurbsSurface
If the grips control a NURBS surface, this returns a pointer to that surface. You can look at but you must NEVER change this surface.
Protected methodNurbsSurfaceGrip
If the grips are control points of a NURBS surface, then this gets the index of the grip that controls the (i,j)-th CV.
Protected methodOnDraw
Draws the grips. In your implementation, override this if you need to draw dynamic elements and then call this base implementation to draw the grips themselves.
Protected methodOnReset
Resets location of all grips to original spots and cleans up stuff that was created by dynamic dragging. This is required when dragging is canceled or in the Copy command when grips are "copied". The override should clean up dynamic workspace stuff.
Protected methodOnResetMeshes
Just before Rhino turns off object grips, it calls this function. If grips have modified any display meshes, they must override this function and restore the meshes to their original states.
Protected methodOnUpdateMesh
Just before Rhino shades an object with grips on, it calls this method to update the display meshes. Grips that modify surface or mesh objects must override this function and modify the display meshes here.
Public methodStatic memberRegisterGripsEnabler
Top
See Also