CustomObjectGripsNewGeometry Method |
If the grips control just one object, then override NewGeometry(). When
NewGeometry() is called, return new geometry calculated from the current
grip locations. This happens once at the end of a grip drag.
Namespace:
Rhino.DocObjects.Custom
Assembly:
RhinoCommon (in RhinoCommon.dll)
Syntax protected virtual GeometryBase NewGeometry()
Protected Overridable Function NewGeometry As GeometryBase
Return Value
Type:
GeometryBaseThe new geometry. The default implementation returns null.
See Also