Click or drag to resize

HostUtils Properties

The HostUtils type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberComputerSerialNumber
Gets the serial number of the computer running Rhino.
Public propertyStatic memberCurrentOSLanguage
Get the current operating system language.
Public propertyStatic memberDeviceId
The DeviceId is a unique, stable ID that anonymously identifies the device that Rhino is running on. It is computed based on hardware information that should not change when the OS is upgraded, or if commonly modified hardware are added or removed from the computer. The machine-specific information is hashed using a cryptographic hash to make it anonymous.
Public propertyStatic memberDeviceName
Name of the computer running Rhino. If the computer is part of a Windows Domain, the computer name has "@[DOMAIN]" appended.
Public propertyStatic memberIsPreRelease
Returns true when Rhino build is Beta or WIP, false otherwise
Public propertyStatic memberOperatingSystemBuildNumber
Returns Operating System Build Number "11763" | "7601" | ... | "Unknown"
Public propertyStatic memberOperatingSystemEdition
Returns Operating System Edition: "Professional" | "ServerDatacenter" | ... | "Unknown"
Public propertyStatic memberOperatingSystemInstallationType
Returns Operating System Installation Type: "Client" | "Server" | "Unknown"
Public propertyStatic memberOperatingSystemProductName
Returns Operating System Edition: "Professional" | "ServerDatacenter" | ... | "Unknown"
Public propertyStatic memberOperatingSystemVersion
Returns Operating System Version "6.1" | "6.3" | ... | "Unknown"
Public propertyStatic memberRhinoAssemblyDirectory
Gets the Rhino system managed assembly directory.
Public propertyStatic memberRunningAsRhinoInside
Indicates whether Rhino is running inside another application. returns false if Rhino.exe is the top-level application. returns true if some other application is the top-level application.
Public propertyStatic memberRunningInDarkMode
Returns true if the host operating system is in dark mode and Rhino supports dark mode.
Public propertyStatic memberRunningInMono
Tests if this process is currently executing under the Mono runtime.
Public propertyStatic memberRunningInNetCore
Tests if this process is currently executing under the .NET Core runtime.
Public propertyStatic memberRunningInNetFramework
Tests if this process is currently executing under the .NET Framework runtime.
Public propertyStatic memberRunningInRhino
Tests if RhinoCommon is currently executing inside of the Rhino.exe process. There are other cases where RhinoCommon could be running; specifically inside of Visual Studio when something like a windows form is being worked on in the resource editor or running stand-alone when compiled to be used as a version of OpenNURBS.
Public propertyStatic memberRunningInWindowsContainer
Tests if this process is currently executing inside a Windows Container.
Public propertyStatic memberRunningOniOS
Tests if this process is currently executing on the iOS platform.
Public propertyStatic memberRunningOnOSX
Tests if this process is currently executing on the Mac OSX platform.
Public propertyStatic memberRunningOnServer
Tests if this process is currently executing in a server environment.
Public propertyStatic memberRunningOnWindows
Tests if this process is currently executing on the Windows platform.
Public propertyStatic memberSendDebugToCommandLine
Gets or sets whether debug messages are printed to the command line.
Top
See Also