Click or drag to resize

MeshFace Properties

The MeshFace type exposes the following members.

Properties
  NameDescription
Public propertyA
Gets or sets the first corner index of the mesh face.
Public propertyB
Gets or sets the second corner index of the mesh face.
Public propertyC
Gets or sets the third corner index of the mesh face.
Public propertyD
Gets or sets the fourth corner index of the mesh face. If D equals C, the mesh face is considered to be a triangle rather than a quad.
Public propertyIsQuad
Gets a value indicating whether or not this mesh face is a quad. A mesh face is considered to be a triangle when C does not equal D, thus it is possible for an Invalid mesh face to also be a quad.
Public propertyIsTriangle
Gets a value indicating whether or not this mesh face is a triangle. A mesh face is considered to be a triangle when C equals D, thus it is possible for an Invalid mesh face to also be a triangle.
Public propertyItem
Gets or sets the vertex index associated with an entry in this face.
Public propertyStatic memberUnset
Gets an Unset MeshFace. Unset faces have Int32.MinValue for all corner indices.
Top
See Also