Click or drag to resize

GeometryBase Properties

The GeometryBase type exposes the following members.

Properties
  NameDescription
Public propertyHasBrepForm
Returns true if the Brep.TryConvertBrep function will be successful for this object
Public propertyIsDeformable
true if object can be accurately modified with "squishy" transformations like projections, shears, and non-uniform scaling.
Public propertyIsDocumentControlled
If true this object may not be modified. Any properties or functions that attempt to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
(Overrides CommonObjectIsDocumentControlled.)
Public propertyObjectType
Useful for switch statements that need to differentiate between basic object types like points, curves, surfaces, and so on.
Public propertyUserStringCount
Gets the amount of user strings.
Top
See Also