Click or drag to resize

Extrusion Properties

The Extrusion type exposes the following members.

Properties
  NameDescription
Public propertyCapCount
Gets the amount of capping surfaces.
Public propertyIsCappedAtBottom
Gets a value indicating whether the surface that fills the bottom profile is existing.
Public propertyIsCappedAtTop
Gets a value indicating whether the surface that fills the top profile is existing.
Public propertyIsMiteredAtEnd
Gets a value indicating whether a miter plane at the end is defined.
Public propertyIsMiteredAtStart
Returns a value indicating whether a miter plane at start is defined.
Public propertyIsSolid
Gets a value indicating whether there is no gap among all surfaces constructing this object.
(Overrides SurfaceIsSolid.)
Public propertyMiterPlaneNormalAtEnd
Gets or sets the normal of the miter plane at the end in profile coordinates. In profile coordinates, 0,0,1 always maps to the extrusion axis
Public propertyMiterPlaneNormalAtStart
Gets or sets the normal of the miter plane at the start in profile coordinates. In profile coordinates, 0,0,1 always maps to the extrusion axis
Public propertyPathEnd
Gets the end point of the path.
Public propertyPathStart
Gets the start point of the path.
Public propertyPathTangent
Gets the up vector of the path.
Public propertyProfileCount
Gets the amount of profile curves.
Top
See Also