Click or drag to resize

Dimension Properties

The Dimension type exposes the following members.

Properties
  NameDescription
Public propertyAlternateBelowLine
Public propertyAltLengthFactor
Public propertyAltLengthResolution
Public propertyAltLengthRoundoff
Public propertyAltPrefix
Public propertyAltSuffix
Public propertyAltToleranceResolution
Public propertyAltUnitsDisplay
Public propertyAltZeroSuppression
Public propertyArrowBlockId1
Public propertyArrowBlockId2
Public propertyArrowFit
Public propertyArrowheadType1
Public propertyArrowheadType2
Public propertyArrowSize
Public propertyBaselineSpacing
Public propertyCentermarkSize
Public propertyCentermarkStyle
Public propertyDetailMeasured
Public propertyDimensionLineExtension
Public propertyDistanceScale
Public propertyExtensionLineExtension
Public propertyExtensionLineOffset
Public propertyFixedExtensionLength
Public propertyFixedLengthExtensionOn
Public propertyForceArrowPosition Obsolete.
Public propertyForceDimensionLineBetweenExtensionLines
Public propertyForceDimLine
Public propertyForceTextPosition Obsolete.
Public propertyLengthFactor
Public propertyLengthResolution
Public propertyLengthRoundoff
Public propertyNumericValue
Gets the numeric value (or measurement), depending on geometry type.

LinearDimension: distance between arrow tips

RadialDimension: radius or diameter depending on type

AngularDimension: angle in radians

Public propertyPlainUserText
Public propertyPrefix
Public propertySuffix
Public propertySuppressExtension1
Public propertySuppressExtension2
Public propertyTextAngleType
Public propertyTextFit
Public propertyTextFormula
Public propertyTextLocation
Public propertyTextOrientation
Public propertyTextPosition
Gets and sets the position of text on the plane.
Public propertyTextRotation
Public propertyToleranceFormat
Public propertyToleranceHeightScale
Public propertyToleranceLowerValue
Public propertyToleranceResolution
Public propertyToleranceUpperValue
Public propertyUseDefaultTextPoint
Public propertyZeroSuppression
Top
See Also