Click or drag to resize

Cylinder Properties

The Cylinder type exposes the following members.

Properties
  NameDescription
Public propertyAxis
Gets the axis direction of the cylinder.
Public propertyBasePlane
Gets or sets the base plane of the cylinder.
Public propertyCenter
Gets the center point of the defining circle.
Public propertyHeight1
Gets or sets the start height of the cylinder. The center of bottom cap is: BasePlane.Origin + Height1 * BasePlane.ZAxis.
Public propertyHeight2
Gets or sets the end height of the cylinder. If the end height equals the start height, the cylinder is presumed to be infinite. The center of top cap is: BasePlane.Origin + Height2 * BasePlane.ZAxis.
Public propertyIsFinite
true if the cylinder is finite (Height0 != Height1) false if the cylinder is infinite.
Public propertyIsValid
Gets a boolean value indicating whether this cylinder is valid.

A valid cylinder is represented by a valid circle and two valid heights.

Public propertyRadius
Gets or sets the radius of the cylinder.
Public propertyTotalHeight
Gets the height of the cylinder. Infinite cylinders have a height of zero, not Double.PositiveInfinity.
Public propertyStatic memberUnset
Gets an invalid Cylinder.
Top
See Also